Who needs Ruby 2.0 right now? Not a lot.

But if for some odd reason, you need really it and have encountered some issues, I hope this helps you move on and get beyond this gibberish stuff.

There are a lot of guides written. Those may work. But if you get something like this:

Error running 'make', please read /Users/katz/.rvm/log/ruby-2.0.0-rc1/make.log

It won't compile without some flags.
If you use homebrew and Mac OS X, great! All you need is to follow this:

brew install openssl
rvm get head
CC=clang  rvm install  2.0.0 -C --enable-shared, --with-openssl-dir=/usr/local

Update:

I found these commands necessary as the above commands no longer work:

rvm get head --autolibs=3 
rvm requirements 
rvm install ruby-2.0.0

Similarly, in Ubuntu. This worked:

sudo apt-get install openssl
rvm get head
rvm install 2.0.0 -C --enable-shared, --with-openssl-dir=/usr/local
comments powered byDisqus

Hello! I am Kat. I've been a developer for several years. When I'm not sitting down, reading and working for long hours, I am traveling to some place of interest.
If you want to reach out, you can send me an email or add me up on Google Plus.