Yesterday I was being slightly adventurous and decided to upgrade to Ruby 1.9.1, the first stable release of the Ruby 1.9 series. It has been a challenge trying to make Rails 2.2.2 work with Ruby 1.9.1. Check out this post.

However I just want to give a warning that currently a lot of gems for the next Rails release aren't working for Ruby 1.9.1 and this includes Rack. What in the world is rack? It sounds new to me as it may sound new to you.

It would help to check out the Rails 2.3 Release Documentation for new features and for some information regarding Rack."Rack aims to provide a minimal API for connecting web servers and web frameworks."

Anyway back to my story, I had to practically install Ruby 1.8.7 again by compiling from source. Same is true for ruby gems 1.3.1. If you're running on Ubuntu 8.10 and have installed 1.9.1 and want to revert to just using 1.8.7 just delete the existing ruby files (whereis ruby). sudo rm -rf /usr/bin/ruby and there may be other files as well that installed on your usr/lib or /usr/local/lib.

Note: if you installed ruby via aptitude, you can use sudo aptitude autoremove.

Assuming you have ruby and ruby gems working. Try ruby -v. The output should be:

ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-linux]

Try gem -v and the output should be:

1.3.1

Before installing Rails 2.3 RC1, make sure you have rack 0.9.1.

sudo gem install rack

Then install mysql if you're using it.

sudo gem install mysql 

Finally install, Rails 2.3 RC1:

gem install rails --source http://gems.rubyonrails.org

You can create your test application and start migrating your existing rails applications to Rails 2.3. In my case, since I didn't require too many gems, I have not experienced any errors so far.

comments powered byDisqus

Hello! I am Kat. I've been a developer for several years. When I'm not sitting down, reading and working for long hours, I am traveling to some place of interest.
If you want to reach out, you can send me an email or add me up on Google Plus.